Exercícios de Lógica de Programação – Variáveis, Operadores e Comandos de Entrada e Saída

Exercícios de Lógica de Programação – Variáveis, Operadores e Comandos de Entrada e Saída

Neste artigo trago alguns exercícios com resolução de Lógica de Programação, usando o software Portugol Studio.

Os exercícios listados aqui cobrem os assuntos Variáveis e Tipos de Dados, Constantes, Operadores variados e Comandos de Entrada e Saída em lógica de programação. Os códigos de resolução dos exercícios estão no final da postagem, logo após a listagem de exercícios.

Bons estudos!

Exercício 1

Escreva um algoritmo que:

  1. Pergunte o nome de uma pessoa;
  2. Pergunte qual o sobrenome da pessoa;
  3. Mostre o nome completo na tela

Exercício 2

Escreva um algoritmo que leia dois valores numéricos e depois mostre a diferença entre eles (o primeiro menos o segundo).

Exercício 3

Crie um algoritmo que leia dois números nas variáveis numA e numB, nessa ordem, e os mostre na tela em ordem inversa, isto é, se os dados lidos forem 7 e 15, por exemplo, devem ser mostrados na ordem 15 e 7, um embaixo do outro (em linhas distintas).

Exercício 4

O sistema de avaliação de determinada disciplina é composto por três provas. A primeira prova tem peso 2, a segunda tem peso 3 e a terceira tem peso 5.

Elabore um algoritmo que calcule a média final de um aluno desta disciplina.

Dica: Neste caso você irá usar uma Média Aritmética Ponderada. Caso tenha dúvidas sobre esse tipo de cálculo, recomendo assistir a esse vídeo: Média Ponderada – Como calcular

Exercício 5

Crie um programa no qual o usuário deverá inserir os valores da altura, largura e profundidade de uma caixa d’água, em cm. No final, exiba o volume dessa caixa d’água.

Dica: Volume = Altura x Largura x Profundidade

Exercício 6

Crie um programa que peça para o usuário informar os valores da base e da altura de um triângulo, em centímetros,, e então mostre na tela o valor da área desse triângulo.

Dica: Área do triângulo = Base x Altura / 2

Exercício 7

Escreva um algoritmo que leia a velocidade de um veículo em km/h, e então calcule e exiba na tela a velocidade convertida em m/s (metros por segundo).

O algoritmo deve também informar quanto tempo irá levar uma viagem na velocidade média informada de São Paulo até o Rio de Janeiro.

Dicas: Para converter de km/h para m/s divida a velocidade pelo fator 3,6. Considere a distância aproximada de São Paulo até o Rio de Janeiro como sendo de 435 km.

Resolução dos Exercícios de Lógica de Programação

Exercício 1

programa
{
  cadeia nome, sobrenome
  funcao inicio()
  {
    escreva("Qual o seu nome? ")
    leia(nome)
    escreva("Qual o seu sobrenome? ")
    leia(sobrenome)
    escreva("Nome completo: " + nome + " " + sobrenome)
  }
}

Exercício 2

programa
{
  inteiro num1, num2, resultado
  funcao inicio()
  {
    escreva("Digite um número inteiro:\n")
    leia(num1)
    escreva("Digite outro número inteiro:\n")
    leia(num2)
    result = num1 - num2
    escreva(num1 + " - " + num2 + " = " + resultado)
  }
}

Exercício 3

programa
{
  inteiro numA, numB
  funcao inicio()
  {
    escreva("Digite um número: ")
    leia(numA)
    escreva("Digite outro número: ")
    leia(numB)
    escreva(numB + "\n" + numA)
  }
}

Exercício 4

programa
{
  real p1, p2, p3, media
  funcao inicio()
  {
    escreva("Qual a primeira nota? ")
    leia(p1)
    escreva("Qual a segunda nota? ")
    leia(p2)
    escreva("Qual a terceira nota? ")
    leia(p3)
    media = (p1 * 2 + p2 * 3 + p3 * 5) / 10
    escreva("Média final: " + media)
  }
}

Exercício 5

programa
{
  inteiro altura, largura, profundidade, volume
  funcao inicio()
  {
    escreva("Qual a altura da caixa d´água em cm? ")
    leia(altura)
    escreva("Qual a largura da caixa d´água em cm? ")
    leia(largura)
    escreva("Qual a profundidade da caixa d´água? em cm ")
    leia(profundidade)
    volume = altura * largura * profundidade
    escreva("A caixa d´água tem capacidade de " + volume + " cm³")
  }
}

Exercício 6

programa
{
  inteiro base, altura, area
  funcao inicio()
  {
    escreva("Qual o valor da base do triângulo, em cm? ")
    leia(base)
    escreva("E qual a altura desse triângulo, em cm? ")
    leia(altura)
    area = base * altura / 2
    escreva("A área do triângulo é de " + area + " cm²")
  }
}

Exercício 7

programa
{
  real velKmH, velMS, tempo
  funcao inicio()
  {
    escreva("Qual a velocidade do veículo, em km/h? ")
    leia(velKmH)
    velMS = velKmH / 3.6
    tempo = 435 / velKmH
    escreva("A velocidade do veículo é de " + velMS + "m/s\n")
    escreva("Uma viagem de São Paulo para o Rio irá levar " + tempo + "horas")
  }
}

 

Sobre Fábio dos Reis (1192 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 30 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Ciência e Tecnologia em geral, adora Viagens e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

Escreva um comentário

Seu e-mail não será divulgado


*