23 – Lógica de Programação – Pesquisa Binária em Vetores (Arrays)

Pesquisa Binária em Vetores (Arrays)

Códigos usados no vídeo

algoritmo "Pesquisa Binária"
 // Função : Estudar a pesquisa binária em vetores
 // Autor : Fábio dos Reis
 // Data : 18/09/2013
 var
 CONTADORA, CONTADORB: inteiro
 NUM, AUX: inteiro
 VET: vetor[1..10] de inteiro
 BUSCA: inteiro

 //Variáveis para busca binária:
 inicial, final, meio: inteiro
 dado_encontrado: logico

 inicio
 //Preencher o array criado
para CONTADORA de 0 ate 1 faca
   para CONTADORB de CONTADORA + 1 ate 2 faca
      se VET[CONTADORA] > VET[CONTADORB] entao
         AUX <-VET[CONTADORB]
         VET[CONTADORB] <- VET[CONTADORA]
         VET[CONTADORA] <- AUX
      fimse
   fimpara
fimpara

 //Exibir o vetor ordenado
 escreval ("Vetor ordenado. Preparado para busca binária:")
 para CONTADORA de 1 ate 10 faca
    escreval(VET[CONTADORA])
 fimpara
 escreval()
//Entrar com valor a pesquisar no vetor
 escreva ("Digite um valor para procurar no vetor:")
 leia (busca)
//Efetuar a pesquisa binária
inicial <- 1
final <- 10
dado_encontrado <- falso
enquanto (inicial <= final) e nao dado_encontrado faca
   meio <- (inicial + final) DIV 2
   se VET[meio] = busca entao
      dado_encontrado <- verdadeiro
   fimse
   se VET[meio] > busca entao
      final <- meio - 1
   senao
      inicial <- meio + 1
   fimse
fimenquanto
//Exibir Resultados da busca
se dado_encontrado = verdadeiro entao
  escreva ("Dado encontrado na posição", meio)
senao
  escreva ("Informação não encontrada no vetor")
fimse
fimalgoritmo
Sobre Fábio dos Reis (1325 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 25 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Unix, Linux e Open Source em geral, adora Eletrônica e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

4 Comentários em 23 – Lógica de Programação – Pesquisa Binária em Vetores (Arrays)

  1. Obrigado pelos vídeos Fábio estão sendo bem úteis para mim que estou iniciando na programação ainda.

    Você por acaso pensa em postar videos sobre C++ ?

    Obrigado!

  2. Adalberto // 19/02/2018 em 19:11 // Responder

    O vídeo está bem legal, porém cria uma certa confusão em relação aos valores das variáveis. Tem momentos que se refere ao “conteúdo” da variável e em outros se refere à “posição” das variáveis.
    Exemplo: Quando “Meio” = 5, apontando para o valor 4, mostra o valor “5” em “meio”. Quando “meio” = 8, apontando para o valor 7, mostra o valor “7” em “meio”.

  3. Tuzin dos programas craft // 13/09/2018 em 15:30 // Responder

    Adorei sua perfil picture Fabio :p kkkkkk rsrsrsrsr lol

Escreva um comentário

Seu e-mail não será divulgado


*