26 – Lógica de Programação – Procedimentos

Lógica de Programação – Procedimentos

Subrotinas

Subrotinas são blocos de códigos escritos para definir tarefas que o programa poderá usar várias vezes durante sua execução, podendo inclusive serem aproveitados em outros programas.

O programador pode escrever subrotinas para definir tarefas específicas que podem ser usadas em muitos pontos do programa. Os comandos que definem as subrotinas são escritos apenas uma vez, e são escondidos de outras rotinas.

Há dois tipos principais de subrotinas em programação estruturada: Procedimentos e Funções. Neste artigo vamos estudar os Procedimentos, e no próximo estudaremos o uso de Funções.

Chamada de Subrotina

Uma subrotina é chamada (invocada para executar suas tarefas) por uma chamada de subrotina.

Uma chamada (call) especifica o nome da subrotina e fornece informações, como argumentos, que a subrotina necessita para realizar sua tarefa designada.

Quando a subrotina completa sua tarefa, retorna o controle ao chamador (rotina que a chamou).

A subrotina também pode retornar um resultado ao chamador.

Procedimentos

Um procedimento é uma subrotina que executa uma tarefa sem no entanto retornar um resultado ao chamador.

Podemos declarar um procedimento em português estruturado da seguinte forma:

procedimento nome-de-procedimento (parâmetros)
Declarações Internas
inicio
     Comandos
fimprocedimento

Exemplo de procedimento

Vamos criar um procedimento de exemplo para escrever uma mensagem na tela para o usuário:

procedimento texto(nome:literal)
inicio
    escreval(“Bom dia “, nome)
fimprocedimento

Chamando o procedimento criado

Vamos usar o código a seguir para chamar (executar) o procedimento criado no exemplo anterior em um algoritmo:

var
   n:literal
procedimento texto(nome:literal)
inicio
    escreval("Bom dia ", nome)
fimprocedimento
inicio
    escreval("Digite seu nome:")
    leia(n)
    texto(n)
fimalgoritmo
 
Ficou com alguma dúvida? Então assista agora ao vídeo da Bóson Treinamentos para ver a explicação sobre Procedimentos em Lógica de Programação:

Sobre Fábio dos Reis (1339 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 25 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Unix, Linux e Open Source em geral, adora Eletrônica e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

2 Comentários em 26 – Lógica de Programação – Procedimentos

  1. JOSE EVANGELISTA // 23/02/2017 em 16:27 // Responder

    OLA BOA TARDE GOSTARIA SE POSSIVEL ENVIAR NOVIDADESOU SE POSSO FEZER PERGUNTAS PARA TIRAR DUVIDAS ABRAÇO.

1 Trackbacks & Pingbacks

  1. Lógica de Programação - Funções - Bóson Treinamentos

Escreva um comentário

Seu e-mail não será divulgado


*