Lógica de Programação – Desvio Condicional Composto (SE…ENTÃO…SENÃO) – 11

Desvio Condicional Composto (SE…ENTÃO…SENÃO)

O desvio condicional composto tem por finalidade tomar decisões de acordo com o resultado de uma condição (teste lógico), da mesma forma que o desvio condicional simples que estudamos na aula anterior. Porém, enquanto o condicional simples somente executa instruções quando o teste condicional retorna verdadeiro, o condicional composto permite criar dois blocos de código:

  • Se o teste lógico retornas verdadeiro, as instruções contidas entre os comandos então e senão serão executadas (como no condicional simples)
  • Entretanto, se o teste lógico retornar falso, as instruções contidas entre os comandos senão e fimse serão executadas.

Sintaxe:

se (condição) então
Instruções caso condição retorne verdadeiro
senão
Instruções caso condição retorne falso
fimse
instruções após executar as instruções de condição verdadeira ou falsa

O fluxograma a seguir ilustra esse processo:

Lógica de Programação - Condicional Composto Se Então Senão

Exemplo: Vamos incrementar o algoritmo que criamos no artigo sobre condicional simples. Queremos agora que o algoritmo verifique a nota média de um aluno, e retorne a mensagem “Aprovado” se essa nota média for maior ou igual ao valor 7, além de ecoar na tela essa nota. Caso a nota média seja menor do que 7, o programa deve retornar a mensagem “Reprovado”, além de mostrar a nota média digitada.

Veja abaixo um fluxograma representando o algoritmo do exemplo:

Desvio condicional composto em lógica de programação

 

E logo a seguir, o algoritmo implementado em português estruturado (no VisualG), usando o condicional composto:

algoritmo RESULTADO_MÉDIA
var
    N1, N2 : inteiro
    MEDIA : real
início
    leia N1
    leia N2
    MEDIA <- (N1 + N2) / 2
    se (media >= 7) entao
       escreva ("Aprovado")
    senao
       escreva ("Reprovado")
    fimse
    escreva ("Sua média é ", MEDIA)
fimalgoritmo

Assista a seguir a um vídeo de nosso canal do YouTube mostrando como usar o desvio condicional composto em algoritmos de teste:

Anterior: Desvio Condicional Simples – SE..ENTÃO

Próximo: Desvio Condicional Encadeado

 

Sobre Fábio dos Reis (1333 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 25 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Unix, Linux e Open Source em geral, adora Eletrônica e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

1 Comentário em Lógica de Programação – Desvio Condicional Composto (SE…ENTÃO…SENÃO) – 11

  1. Código:

    algoritmo “RESULTADO_MEDIA”
    // Função : Estudo de Condicional Composto
    // Autor : Fábio dos Reis
    // Data : 03/04/2013

    var
    N1, N2 : inteiro
    MEDIA : real
    inicio
    escreval (“Digite a primeira nota: “)
    leia (N1)
    escreval (“Digite a segunda nota: “)
    leia (N2)
    MEDIA < - (N1 + N2) / 2 se (MEDIA >= 7) entao
    escreval (“Aprovado”)
    senao
    escreva (“Reprovado”)
    fimse
    fimalgoritmo

1 Trackbacks & Pingbacks

  1. 10 - Lógica de Programação - Desvio Condicional Simples (SE...ENTÃO) - Bóson Treinamentos em Tecnologia

Escreva um comentário

Seu e-mail não será divulgado


*