10 – Lógica de Programação – Desvio Condicional Simples (SE…ENTÃO)

Desvio Condicional Simples (SE…ENTÃO)

Um desvio condicional tem por finalidade tomar uma decisão de acordo com o resultado de uma condição (teste lógico), e então executar um bloco de códigos que irá depender do resultado dessa condição. 

O desvio condicional simples permite executar um bloco de código caso o resultado do teste seja verdadeiro, ignorando um resultado falso.

Sintaxe:

se (condição) então
   Instruções caso condição retorne verdadeiro
fimse
   instruções que serão executadas independentemente do resultado do teste

SE esse teste lógico (condição) retorna verdadeiro, as instruções contidas entre os comandos ENTÃO e FIMSE são executadas; caso contrário, nada ocorre, e o programa segue seu fluxo normal de execução.

Exemplo

Criar um algoritmo que verifique a nota média de um aluno, e retorne a mensagem “Aprovado” se essa nota média for maior ou igual ao valor 7, além de ecoar na tela essa nota. Se a nota média for menor do que 7, o programa deve apenas mostrar a nota média digitada.

Veja abaixo um fluxograma representando nosso algoritmo:

Desvio Condicional Simples - Lógica de Programação

E logo a seguir, o algoritmo implementado em português estruturado (no VisualG), usando o condicional simples:

algoritmo RESULTADO_MÉDIA
var
    N1, N2 : inteiro
    MEDIA : real
início
    leia (N1)
    leia (N2)
    MEDIA <- (N1 + N2) / 2
    se (media >= 7) entao
      escreval (“Aprovado”)
    fimse
    escreva (“Sua média é “, MEDIA)
fimalgoritmo

Assista a seguir a um vídeo de nosso canal do YouTube que mostra como usar o desvio condicional simples:

Anterior: Operadores Lógicos e Expressões Lógicas

Próximo: Desvio Condicional Composto – SE .. ENTÃO .. SENÃO

 

Sobre Fábio dos Reis (1278 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 25 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Unix, Linux e Open Source em geral, adora Eletrônica e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

1 Trackbacks & Pingbacks

  1. Curso de PHP - Estruturas de Controle Condicional if, elseif, else

Escreva um comentário

Seu e-mail não será divulgado


*