25 – Lógica de Programação – Comando Caso – Escolhas múltiplas

Lógica de Programação – Comando Caso – Escolhas múltiplas

O comando caso é utilizado para que seja possível escolher uma opção dentre várias existentes, eliminando a necessidade de se usar diversos Se..Então encadeados.

Isso simplifica a codificação do algoritmo, e facilita sua depuração e atualização.

Esse comando testa uma condição, e dependendo do resultado, executará os códigos associados.

Comando Caso – Sintaxe

A sintaxe pode variar um pouco de uma linguagem para outra, e no VisualG você a usará assim:

escolha <variável / expressão)
   caso <valor1>
comandos a executar
   caso <valor2>
comandos a executar
   caso <valor3>
comandos a executar
   outrocaso
comandos-padrão
fimescolha

Exemplo de uso do comando Caso – Exibindo uma mensagem de acordo com uma letra escolhida:

var
   x: literal
inicio
   escreval (“Digite uma letra:”)
   leia (x)
   escolha x
     caso “a”
        escreva(“Você digitou a letra A”)
     caso “b”
       escreva(“Você digitou a letra B”)
     outrocaso
     escreva(“Você digitou uma outra letra”)
fimescolha
fimalgoritmo

É isso aí! Assista agora ao vídeo sobre o comando caso no canal da Bóson Treinamentos:

Sobre Fábio dos Reis (1347 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 25 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Unix, Linux e Open Source em geral, adora Eletrônica e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

6 Comentários em 25 – Lógica de Programação – Comando Caso – Escolhas múltiplas

  1. Fabio estava acompanhando suas aulas e chegando na de numero 25 eu vi que foi a última que foi postada em set/2013 sobre programação logica. Que houve não vai ter continuação? será que vai ser como outras aulas que agente acompanha e fica pelo meio do caminho? Aguardo resposta.

    • Já temos mais algumas aulas de lógica de programação no site Eduardo, e há mais algumas a caminho. Abraço!

  2. Adalberto // 29/05/2014 em 22:30 // Responder

    Fábio, as aulas de lógica terminar na 25 ou tem mais?

  3. rodrigo almeida maciel // 17/06/2014 em 1:14 // Responder

    bom dia

    queria muito saber sobre os contatos de email da Boson .treinamentos .

    att; Rodrigo Maciel

1 Trackbacks & Pingbacks

  1. Lógica de Programação - Desvio Condicional Aninhado (SE...ENTÃO...SENÃO...SE) - 12 - Bóson Treinamentos em Tecnologia

Escreva um comentário

Seu e-mail não será divulgado


*