Lógica de Programação – Vetores – Exemplo de uso no VisualG – 19

Lógica de Programação – Vetores – Exemplo de uso no VisualG

Neste exercício iremos criar um programa que permita entrar com 4 notas de um aluno, armazená-las na memória, calcular a média aritmética dessas notas e então exibir essa média na tela.
Logo após, exibir também as notas que foram usadas no cálculo da média.

Código-fonte

Var
NOTAS : vetor [0..3] de real
SOMA, MEDIA : real
i : inteiro
Inicio
SOMA <- 0
escreval ("Digite as quatro notas do aluno: ")

para i de 0 ate 3 faca
   leia (NOTAS[i])
   soma <- soma + NOTAS[i]
fimpara

MEDIA <- soma / 4
escreval ("A média é ", MEDIA)

para i de 0 ate 3 faca
   escreval ("Nota ", i + 1, ": ", NOTAS[i])
fimpara
Fimalgoritmo

O fluxograma a seguir ilustra o funcionamento desse algoritmo:

Exercício sobre vetores - fluxograma

Para entender melhor o funcionamento desse programa, assista ao vídeo a seguir, do canal da Bóson Treinamentos no YouTube:

Anterior: Atribuição de Valores e Leitura de Dados em Vetores

Próximo: Técnica para trocar valores de variáveis

 

Sobre Fábio dos Reis (1325 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 25 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Unix, Linux e Open Source em geral, adora Eletrônica e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

Escreva um comentário

Seu e-mail não será divulgado


*