Lógica de Programação – Pesquisa Sequencial em Vetores (Arrays) – 22

Pesquisa Sequencial em Vetores (Arrays)

Código para o VisualG:

algoritmo "Pesquisa Sequencial em Arrays"
 // Função : Buscar dados usando a técnica da pesquisa sequencial em um array
 // Autor : Fábio dos Reis
 // Data : 13/09/2013
 var
 VET: vetor [1..3] de inteiro
 NUM, POSICAO: inteiro
 inicio
 // preencher o array
 PARA POSICAO DE 1 ATE 3 FACA
    ESCREVAL ("Digite um número para inserir no array:")
    LEIA (VET[POSICAO])
 FIMPARA
 //entrar com valor a pesquisar
 ESCREVAL ("Digite um número para pesquisar no array:")
 LEIA (NUM)
 POSICAO <- 1
//pesquisar no array e exibir o resultado da busca
 ENQUANTO (POSICAO < 3) e (VET[POSICAO] <> NUM) FACA
    POSICAO <- POSICAO + 1
 FIMENQUANTO
 SE VET[POSICAO] = NUM ENTAO
    ESCREVA ("Número encontrado na posição ", POSICAO)
 SENAO
    ESCREVA ("Número não encontrado no array")
 FIMSE
 fimalgoritmo

 

Anterior: Algoritmo para Ordenação de Vetores

Próximo: Pesquisa Binária em Vetores

 

Sobre Fábio dos Reis (1332 Artigos)
Fábio dos Reis trabalha com tecnologias variadas há mais de 25 anos, tendo atuado nos campos de Eletrônica, Telecomunicações, Programação de Computadores e Redes de Dados. É um entusiasta de Unix, Linux e Open Source em geral, adora Eletrônica e Música, e estuda idiomas, além de ministrar cursos e palestras sobre diversas tecnologias em São Paulo e outras cidades do Brasil.
Contato: Website

Escreva um comentário

Seu e-mail não será divulgado


*